Hammer 6.9 "Permission Denied" Error; Hammer Support


Hi - I updated to Hammer 6.9 recently, and immediately got a build error when it launched (it was building fine in 6.8).

The error starts with “Permission Denied - /ugene-demo” (this is the build folder I have set). I’m guessing the app doesn’t have permission to write there now for some reason and I probably need to run some sort of chmod command…but I’m not very savvy with unix permissions, so I wanted to see if this was a known issue or had a recommended fix before wasting more time researching or messing up my file system.

Don’t know if this is an appropriate place for support / issues, but the docs page on the Hammer website (and all linked pages for that matter) aren’t working at the moment. If there is an appropriate/official support process for Hammer customers, I’d certainly appreciate it if someone could point me in the right direction (or add some information to this forum)! :slight_smile:.


Hey Ajarora,

I ran into this error. After some playing around I found changing the path to build directory from a relative path to an absolute path worked for me. This may work for you also.

A tip to get the absolute path to the build folder is to open up a finder window and navigate to the build folder. Then open up a terminal window from applications/utilities folder and drag the build folder from your finder window into your terminal window and this should provide you with the absolute path to your project build folder. Add this path to the hammer.json file in your project folder.

Hope this helps :slight_smile: